UTV Chat talk Forum Board Rhino Clones ODES UTVS HiSun Massimo Motor Bennche Qlink Linhai Supermach USTitan 700cc UTV Cheap 500cc UTV Wholesale

Activity Stream

Filter
Sort By Time Show
Recent Recent Popular Popular Anytime Anytime Last 7 Days Last 7 Days Last 30 Days Last 30 Days All All Photos Photos Forum Forums
  • Joeski's Avatar
    01-13-2019, 11:00 AM
    Joeski started a thread 2015 dominator cv joint in Odes
    I have a 2015 Dominator and my bearing went out when a friend was driving it and he tore up the cv joint on the passenger sid. does anyone know the...
    0 replies | 18 view(s)
  • Joeski's Avatar
    01-13-2019, 10:19 AM
    ODES and its dealers are horrible.. I have a 2015 dominator 4 seater and have had troubles with it contstantly.. dealer I purchased it from was doing...
    13 replies | 10341 view(s)
  • Flanman55's Avatar
    01-05-2019, 01:28 AM
    Looking for a new set of rims. Was wondering what the offsets are on stock wheels and what wheels would give about an 1" in stance without spacers? ...
    0 replies | 48 view(s)
  • Flanman55's Avatar
    01-04-2019, 07:08 PM
    Flanman55 replied to a thread Hello in General UTV Discussion
    Thanks for the response Dave. I did jack up the front end before I filled it and bled it out with that screw. I found now that the temp sensor is...
    2 replies | 196 view(s)
  • AZ_Dave's Avatar
    01-03-2019, 03:23 PM
    AZ_Dave replied to a thread Hello in General UTV Discussion
    Hi This may or not be your issue. If the coolant was recently changed, and the air was't purged from the lines you could have an air bubble causing...
    2 replies | 196 view(s)
  • Flanman55's Avatar
    01-03-2019, 01:55 AM
    Flanman55 started a thread Hello in General UTV Discussion
    I recently bought a used Supermach 700 Hisun. Runs ok but the coolant light is constantly on and the coolant level is good. The fan is on a bypass...
    2 replies | 196 view(s)
  • RockyRider's Avatar
    01-02-2019, 01:02 PM
    Started running rough several weeks ago. No guts on hills or with load, wont idle, sputters and stalls after it starts to warm up. Will start back...
    0 replies | 75 view(s)
  • gmcman355's Avatar
    12-23-2018, 09:29 PM
    Has anybody had any luck curing the lean running condition these have? Ive got a 2016 dominator x4 800 and have had a lean running condition pretty...
    0 replies | 166 view(s)
  • Statler's Avatar
    12-18-2018, 09:53 AM
    I'm not sure, but what do you mean you've been burned before? Are you looking to buy the 2018 model? I'm sure any vendor would be able to tell you...
    1 replies | 615 view(s)
No More Results