UTV Chat talk Forum Board Rhino Clones ODES UTVS HiSun Massimo Motor Bennche Qlink Linhai Supermach USTitan 700cc UTV Cheap 500cc UTV Wholesale
Results 1 to 5 of 5

Thread: #1 cylinder?

  1. #1
    Newbie
    Join Date
    Nov 2016
    Posts
    6
    Post Thanks / Like

    #1 cylinder?

    2011 hisun 800 recently did crank reinstalled and fired up #1 cylinder runs for a couple seconds and cuts out have 150psi compression, fuel and spark any ideas of where to look ( removed injector and ran the machine to see fuel and spark) swapped coils wires and ran out of ideas and help would be appreciated

  2. #2
    Newbie
    Join Date
    Nov 2016
    Posts
    6
    Post Thanks / Like
    Can some explain what the last 2 replies mean sorry for my lack of understanding

  3. #3
    Senior Member 4getful2's Avatar
    Join Date
    Jul 2011
    Location
    Litchfield, Illinois
    Posts
    417
    Post Thanks / Like
    try swapping injectors and see what that does. You may also try swapping o2 sensors. if no change, get a voltage reading on front and rear o2 sensors and show what the results are. check all connections, it may be time for a new ECM.
    '14 Massimo 800
    '08 Hisun 700 (gone)
    '03 Polaris 500 sportsman

  4. #4
    Newbie
    Join Date
    Nov 2016
    Posts
    6
    Post Thanks / Like
    Will have to get readings for o2 sensors, have tried ecm have 3 now lol starting to get a little pricey but I am still open to suggestions think the mapp sensor would have any play in this? Thank you for your response Cory (I did swap sensors prior but no change)

  5. #5
    Senior Member 4getful2's Avatar
    Join Date
    Jul 2011
    Location
    Litchfield, Illinois
    Posts
    417
    Post Thanks / Like
    Not the map sensor. It checks for air temp. and the amount of air coming in as a whole and not just one cylinder.
    Since you've tried different ecm's and had the same results. You have verified that it is in time(cam timing) and valves are set correctly? Since the specs. are so tight, I set mine on the loose side of the spec.
    Might be time to get the ohmmeter out and check the wiring harness from the motor to the ecm.
    '14 Massimo 800
    '08 Hisun 700 (gone)
    '03 Polaris 500 sportsman

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •