UTV Chat talk Forum Board Rhino Clones ODES UTVS HiSun Massimo Motor Bennche Qlink Linhai Supermach USTitan 700cc UTV Cheap 500cc UTV Wholesale
Results 1 to 7 of 7

Thread: 2012 Bennche bogs down

  1. #1
    Newbie
    Join Date
    Jul 2017
    Posts
    5
    Post Thanks / Like

    2012 Bennche bogs down

    Hey all,
    My 2012 Bennche Bighorn 700 Crew starts and idles fine. Shortly after warming up, it will cut out and bog down when driving at a steady speed (25mph in low range). When I hit the gas it seems to come out of it, but feels like it is holding back. I have changed oil & filter, air filter and spark plug. No changes. I unplugged the O2 sensor and it made it a little worse. I removed the inline fuel filter and that made no difference. Any ideas where to check next? Thanks a ton!

  2. #2
    Senior Member wyodlr's Avatar
    Join Date
    Oct 2011
    Location
    Cody Wyoming
    Posts
    911
    Post Thanks / Like
    at 25mph in low you are probably hitting the rev limiter
    2013 MSU-1100

  3. #3
    Newbie
    Join Date
    Jul 2017
    Posts
    5
    Post Thanks / Like
    Not a rev limiter issue. Only at 4300 rpm @ 25. Will do nearly 40 before rev limiter in low. I also have a rev limiter bypass button to verify. Thanks for the input tho!

  4. #4
    Senior Member wyodlr's Avatar
    Join Date
    Oct 2011
    Location
    Cody Wyoming
    Posts
    911
    Post Thanks / Like
    Have you checked the belt sheaves to make sure they slide ok?
    2013 MSU-1100

  5. #5
    Newbie
    Join Date
    Jul 2017
    Posts
    5
    Post Thanks / Like
    Yes. I just replaced the wet clutch and checked everything during assembly and replaced the belt. This issued existed before the clutch was replaced. When it bogs down, if I keep a steady throttle it sputters.

  6. #6
    Newbie
    Join Date
    Jul 2017
    Posts
    5
    Post Thanks / Like
    I went thru all of the wiring this afternoon. Found no issues. Really seems like it is either a fuel pressure/supply issue or possibly throttle position sensor? Does anyone have a cross reference part # for a TPS? I will try to test fuel pressure tomorrow to hopefully rule that out.

  7. #7
    Newbie
    Join Date
    Oct 2014
    Posts
    15
    Post Thanks / Like
    My Massimo 500 is doing the same thing, please let us know how you resolve this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •