UTV Chat talk Forum Board Rhino Clones ODES UTVS HiSun Massimo Motor Bennche Qlink Linhai Supermach USTitan 700cc UTV Cheap 500cc UTV Wholesale
Results 1 to 2 of 2

Thread: IAC Bypass?

  1. #1
    Join Date
    Oct 2015
    North Carolina
    Post Thanks / Like

    IAC Bypass?

    Is there anyway to bypass the IAC on the throttle body? I feel like the hole could be plugged with some RVT and then use the setscrew for the throttle plate to adjust idle RPM...
    I've spoke with someone with Bennche and apparently the new models dont have an IAC. After looking on sportsmancountry.com i confirmed that they don't have an IAC.
    I ask this because I've had to replace mine almost every year and I'm always having idle issues and fuel issues. I run a fuel pressure gauge so i know I'm sitting around 45psi so the only thing i can think of is sometimes when the machine is warm that this valve opens and allows to much air in causing a lean condition. I actually had this happen the other day. Had been riding for 20-30 min and parked but left the motor running. As i sat there i noticed that my afr slowly creeping up from a 12.1 all the way up to a 16.1 before finally stalling. I just checked the vent for the fuel tank and its good, fuel filter is clean, and fuel pressure stays steady. Only problem i can think of now is too much air getting in and it cant be a vacuum leak because it doesnt happen every time. every once in a while.

    Please let me know if anyone has had any success with plugging the port to the IAC and how it affected cranking the motor in the winter time as mine gets used for hunting and need it to crank when its below 32 outside......

  2. #2
    Join Date
    May 2019
    Post Thanks / Like
    Ive kinda got the same problem with a 500 Bennche Bighorn. It sometimes will crank and run great and then other times you have to turn it over a lot and still no crank, turn key off and go back and fires right up. Have cleaned the throttle body, air filter, and just cant put my finger on this problem. Also unplugged all connections and cleaned the O2 sensor. Even ran it with O2 unplugged and seemed better and then started doing this again. Any suggestions? As many as they sell there should be numerous problems out there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts