UTV Chat talk Forum Board Rhino Clones ODES UTVS HiSun Massimo Motor Bennche Qlink Linhai Supermach USTitan 700cc UTV Cheap 500cc UTV Wholesale
Results 1 to 3 of 3

Thread: Hello

  1. #1
    Newbie
    Join Date
    Dec 2018
    Location
    Alberta
    Posts
    3
    Post Thanks / Like

    Hello

    I recently bought a used Supermach 700 Hisun. Runs ok but the coolant light is constantly on and the coolant level is good. The fan is on a bypass switch and the thermostat area doesnt feel overly warm. And ideas on how to fix the light to actually work correctly?


    Thanks

  2. #2
    Newbie
    Join Date
    Jul 2013
    Location
    Arizona
    Posts
    21
    Post Thanks / Like
    AIR BLEED BOLT.gif

    Hi This may or not be your issue. If the coolant was recently changed, and the air was't purged from the lines you could have an air bubble causing the issue. The manual says "Fill the cooling system with the
    recommended coolant until coolant comes out of the hole for the air bleed bolt."

  3. #3
    Newbie
    Join Date
    Dec 2018
    Location
    Alberta
    Posts
    3
    Post Thanks / Like
    Thanks for the response Dave. I did jack up the front end before I filled it and bled it out with that screw. I found now that the temp sensor is unhooked but can't for the life of me find where it plugs back in, lol

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •