UTV Chat talk Forum Board Rhino Clones ODES UTVS HiSun Massimo Motor Bennche Qlink Linhai Supermach USTitan 700cc UTV Cheap 500cc UTV Wholesale
Results 1 to 4 of 4

Thread: 500 hisun, electric fan not starting, temp light is coming on

  1. #1
    Newbie
    Join Date
    Apr 2015
    Posts
    1
    Post Thanks / Like

    500 hisun, electric fan not starting, temp light is coming on

    he electric fan is running if you hot wire it, but it wont come on when its running, hence the temp light comes on.

  2. #2
    Newbie
    Join Date
    Jul 2014
    Posts
    10
    Post Thanks / Like
    Check the switch that turns the fan on and off. It is usually on the radiator or sometimes the head. It is controlled by temperature. It is normally open (off) and when it gets to a certain temperature it closes (on) and the fan comes on. When the fan comes on, it cools the coolant to a point that the switch opens again turning the fan off. Common problem with many makes of liquid cooled machines, frequently has only one wire, the ground and the switch is grounded to the radiator/head
    Pedrodawg
    Ride Hard, Ride Proud, Ride Free, Ride

  3. #3
    Senior Member 231 Motorsports's Avatar
    Join Date
    Jan 2011
    Location
    Huntingburg, Indiana, United States
    Posts
    917
    Post Thanks / Like
    On the Hisun the switch is in the radiator , it is two wire , right side of the radiator. If you jump it out and the fan runs it's bad , if not the diode in the harness under the battery box is the problem. Most likely it's the diode. Also make sure both radiator hoses are hot , if you are airlocked , the antifreeze won't circulate , and it will overheat and the fan won't run also.
    231 Motorsports LLC. (812)482-3606 Parts for your atv , no matter what brand it is ! Even if you can't pronounce it! Also the areas only Argo amphibious atv dealer

  4. Thanks bull4545 thanked for this post
    Likes bull4545 liked this post
  5. #4
    Newbie
    Join Date
    Nov 2014
    Posts
    14
    Post Thanks / Like
    Quote Originally Posted by 231 Motorsports View Post
    On the Hisun the switch is in the radiator , it is two wire , right side of the radiator. If you jump it out and the fan runs it's bad , if not the diode in the harness under the battery box is the problem. Most likely it's the diode. Also make sure both radiator hoses are hot , if you are airlocked , the antifreeze won't circulate , and it will overheat and the fan won't run also.
    Does this Diode have a PART number is it generic or specific to MSU
    2015 Massimo MSU 500
    Slug kit
    Purple spring and washer spacer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •