UTV Chat talk Forum Board Rhino Clones ODES UTVS HiSun Massimo Motor Bennche Qlink Linhai Supermach USTitan 700cc UTV Cheap 500cc UTV Wholesale
Results 1 to 5 of 5

Thread: 2012 800 EFI No Fire, newbie help

  1. #1
    Newbie
    Join Date
    May 2015
    Location
    Charleston WV
    Posts
    3
    Post Thanks / Like

    2012 800 EFI No Fire, newbie help

    I just got this from a guy that gave up on it. Said it was doing great and one day it just wouldn't do anything. After bringing it home and cleaning it up real good, Had a bunch of mud cakes around battery box and such. I finally got it to crank but no fire. With my light tester I found a bad ground but no power going to the coil packs. 2 striped wires going to them. Well I traced them down and thought it needed a new ECU box and ordered one on ebay and that didn't fix anything. Now I am starting to believe it may be one of them relays beside the box. fuses checked out ok. Could it be a crank sensor? These are guesses from other posts on here. ANY help will be appreciated . I ordered a cd with a wiring diagram should be in next week but hoping to tinker with it this weekend if I can get some ideas? Thanks

  2. #2
    Senior Member wyodlr's Avatar
    Join Date
    Oct 2011
    Location
    Cody Wyoming
    Posts
    938
    Post Thanks / Like
    Welcome to the forum. What brand of utv is it?
    2016 Honda Pioneer 1000-5

  3. #3
    Newbie
    Join Date
    May 2015
    Location
    Charleston WV
    Posts
    3
    Post Thanks / Like
    Its a Benchee Spire 2012 800, Thanks

  4. #4
    Senior Member gunsht59's Avatar
    Join Date
    May 2013
    Location
    Spring Hill Florida
    Posts
    518
    Post Thanks / Like
    I am starting to think those crank position sensors are alot of the no spark problems on the 800's Mine has not gone yet 2012 but I have a spare just in case,I think they are only around 35 bucks and one bolt
    Last edited by gunsht59; 06-02-2015 at 09:56 PM.

  5. #5
    Senior Member wyodlr's Avatar
    Join Date
    Oct 2011
    Location
    Cody Wyoming
    Posts
    938
    Post Thanks / Like
    Every 800 around here that has been run a lot has had the crank sensor replaced at least once, they breakdown with heat
    2016 Honda Pioneer 1000-5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •